Hey there!

It looks like you're enjoying Hesaptablosu - Akademik Excel Forumu but haven't created an account yet. Why not take a minute to register for your own free account now? As a member you get free access to all of our forums and posts plus the ability to post your own messages, communicate directly with other members and much more. Register now!

Already a member? Login at the top of this page to stop seeing this message.

Toplam 3 sonuçtan 1 ile 3 arasındakiler gösteriliyor.

Konu: DÜŞEYARA

  1. #1
    Üye
    Üyelik tarihi
    Mar 2015
    Mesajlar
    55

    DÜŞEYARA

    =DÜŞEYARA(B9;ESAJO!$Z$1:$AA$10000;2;YANLIŞ)

    B9 hücresinde aranan değerin belirtilen aralıkta bulunmaması durumunda değer olarak #YOK
    yazılmaktadır. Bu değerin, #YOK yerine 0 (sıfır) olarak yazdırılması mümkün müdür acaba?


    Teşekkürler.

  2. #2
    Kıdemli Üye
    Üyelik tarihi
    Jun 2010
    Nereden
    Erbaa
    Versiyon
    2010 TR
    Mesajlar
    1.020
    Soru-Cevap: 64 - M. Temel Korkmaz

    Grup halindeki toplamalarda hücrelerden herhangi bir #N/A olduğu durumda sonucu da etkisiz kılıyor. Bir grup toplamada sadece rakamları toplamak nasıl sağlanabilir?
    Cevap olarak Üstadın önceki bir cevabını ekliyorum. Linki yan tarafta.
    http://www.excel.gen.tr/SoruCevap_00064.asp
    Bu tür hata mesajlarının hepsinde aynı yöntemi uygulamak mümkündür. Unutulmamalıdır ki, hata mesajı olan hücrede bir formül bulunmaktadır. Farzedelim ki hatalı hücrede aşağıdaki gibi bir formül olsun.=DÜŞEYARA(B1;C111;2;0)

    Düşeyara ile aranılan veri bulunamadığında hücrede #YOK hata değeri olacaktır. Dolayısı ile bu da o hücrenin içerisinde bulunduğu bir toplama dizisini hatalı olarak gösterecektir. O halde bu hücreye ya boşluk değeri ya da sıfır değeri atayabiliriz. Ama unutmayınız sıfır değeri çarpma işleminde sorun çıkartabilir. O halde boşluk değeri atayalım. Yukarıdaki formülü aşağıdaki gibi değiştiriniz.
    =EĞER(EHATALIYSA(DÜŞEYARA(B1;C111;2;0));"";DÜŞEYARA(B1;C111;2;0))

    Yaptığımız tek şey normalolarak bildiğimiz EĞER formülü ile birlikte EHATALIYSA formülünü kullanmaktır. Formülün anlaşılması için aşağıdaki açıklamayı inceleyiniz.

    =EĞER(HATALIYSA(formül);"";formül))
    "Eğer formül hatalı sonuç veriyorsa hücreyi boş bırak, değil ise formül sonucunu yazdır."

    NOT:Çift tırnak yerine 0 yazmalısınız.
    Konu behcet tarafından (06.08.2016 Saat 21:20 ) değiştirilmiştir.

  3. #3
    Üye
    Üyelik tarihi
    Mar 2015
    Mesajlar
    55
    Çok teşekkürler. Hemen deneyeceğim.
    Hayırlı günler

Konu Bilgisi

Users Browsing this Thread

Şu anda 1 üyemiz bu konuya göz atıyor. (0 kayıtlı üye ve 1 misafir.)

Bu Konu İçin Etiketler

Yetkileriniz

  • Konu Acma Yetkiniz Yok
  • Cevap Yazma Yetkiniz Yok
  • Eklenti Yükleme Yetkiniz Yok
  • Mesajınızı Değiştirme Yetkiniz Yok
  •