PDA

Orijinalini görmek için tıklayınız : ara bul eşleştir ve getir



savasbayram
01.10.2010, 00:02
Merhaba,

Fiyatlandırma sayfasındaki B sütünuna bir formül ihtiyacım var.
"fiyatlandırma sayfasındaki B2 hücresi", fiyat listesinde 10300155501 kodlu ürünü bulup, fiyat listesinde B sütünundaki kodla kesişen fiyatı , fiyatlandırma sayfasındaki B2 hücresine değer olarak yapıştırabilirmi?
Bu şekilde tüm ürünlerin fiyatını tek tek aramadan fiyat teklifi ve fatura hazırlayabilmeyi umuyorum. Tabloları excel olarak hazırladım ancak buraya ekleyemedim. Umarım anlaşılıyordur.

Saygılarımla


FİYATLANDIRMA SAYFASI
A B
1 stok kodu satış fiyatı
2 10300155501 0
3 10300155505 0
4 10300155515 0
5 10300155517 0
6 10300155518 0


FİYAT LİSTESİ SAYFASI

A B
1 kod satış fiyatı
2
3 26105822011 51,60
4 10200165001 21,40
5 10200165002 21,40
6 10200165003 20,20
7 10200165004 20,50
8 10200165005 39,30
9 10300155501 33,00
10 10300155502 33,00
11 10300155503 33,00
12 10300155504 33,00
13 10300155505 33,00
14 10300155506 33,00
15 10300155511 33,00
16 10300155512 24,30
17 10300155513 24,30
18 10300155514 24,30
19 10300155515 24,30
20 10300155516 24,30
21 10300155517 24,30
22 10300155518 24,30
23 10220155501 8,50
24 11201438001 20,30
25 11206438001 20,20

Yakup Karaman
01.10.2010, 09:29
Merhaba,

Aradığınız formül DÜŞEYARA'dır. Aşağıdaki şekilde kullanabilirsiniz.

=DÜŞEYARA(A2;'FİYAT LİSTESİ'!A:B;2;0)

Eğer forumda arama yaptırırsanız düşeyara ile ilgili daha birçok örnek ve anlatım bulabilirsiniz. Ayrıca aşağıda verdiğim bağlantıya tıklarsanız orada da güzel bir anlatım bulacaksınız.
http://www.excel.gen.tr/index.php?option=com_content&view=article&id=120:dueeyara-ilevini-kullandmda-istediim-sonucu-alamyorum&catid=17:lev&Itemid=39

savasbayram
01.10.2010, 14:51
Teşekkür ederim. Verdiğiniz cevap işimi gördü. Ancak bir konuda deneme yanılma yapmak zorunda kaldım. Arama yaptırılan belgede , aranan ve getirelecek değer yan yana hücrelerde olması gerekiyormuş.
Teşekkürler

Yakup Karaman
01.10.2010, 14:58
Elbette yan yana olması gerekiyor; ama bitişik olması gerekmiyor. Arada başka sütunlar da olabilir.
Düşeyara fonksiyonunun diğer bir şartı da şudur: Aradığınız değer bulup getireceğiniz değerden önceki bir sütunda olmalıdır.